PDA

View Full Version : [FIXED] [V0.6] Error when setting Tab visible="false"



Jurke
Sep 08, 2008, 12:35 PM
Hi
I have a problem, Im trying to set a simple Tab to visible="false"



<ext:TabPanel ID="tabpage1" runat="server">
<Tabs>
<ext:Tab Visible="false" ID="Tab1" Title="Tab1"></ext:Tab>
</Tabs>
</ext:TabPanel>


This generates a runtime errror in IE, saying "Error: ':' expected", is this not supose to work or is it a bug? Im running version 0.5.4 of coollite and Visual studio 2008.

Does anyone know how to solve this?

Best regards
Mikael

geoffrey.mcgill
Sep 08, 2008, 4:05 PM
Hi Mikael,

Thanks for reporting this bug.


There was a logic bug in how the JavaScript configuration script was being generated for the TabPanel. 


The fix has been committed to svn and will be available with the v0.6 release. 


Currently, at least one one Tab must have Visible="true".

Jurke
Sep 09, 2008, 4:31 AM
Thaks for the reply

But I still get the same error even if I have 2 tabs and only sets one of the to visible="false".






<ext:TabPanel ID="tabpage1" runat="server">
<Tabs>
<ext:Tab Visible="true" ID="Tab1" Title="Tab1"></ext:Tab>
<ext:Tab Visible="false" ID="Tab2" Title="Tab2"></ext:Tab>
</Tabs>
</ext:TabPanel>


Best regards
Mikael

geoffrey.mcgill
Sep 09, 2008, 4:12 PM
Hi Mikael,

I copy/paste your sample into a test page and it work properly with the latest source code. 


Once v0.6 has been released this should be working as expected. 

Jurke
Sep 10, 2008, 4:17 AM
Hi Geoffrey
I had not complete the update to 0.6, thats why it was not working. But now it is!
Thank you! Im testing the new version 0.6 out its working very good!

Best regards
Mikael