PDA

View Full Version : [CLOSED] ext.net controls not working in Internet Explorer after deployment on server?



aditya
Feb 24, 2014, 12:44 PM
Hi, i have already asked about this in http://forums.ext.net/showthread.php?27186 http://forums.ext.net/showthread.php?27397-CLOSED-Ext-NET-controls-is-not-rended-in-IE&p=121880#post121880
but my problem still not resolved. Ext.net controls are not rendering in Internet Explorer? I am giving you a live link to reproduce problem here is the link
https://eimpact.insightresults.com/eiDev/Authentication/Web/WebLogin.aspx?SHINE=4Ic3uF7JAyccktxlomyVoHdQZgE8OE ADT474xlQNUoBZ6on0ukcPbq/OeDJaswLrL0/0VYFnG5p32FQ5LiTHhySzh8geQ/ug1hZ86JsAQNS12OuP7dUtK7G71rW5q2qPmv4ttfnli4pG3HPE 8/HmRdtY3TuJbe2VmZ5k+PpqDry+RkKBLwa9zw31z2BvZ/SkMB0hm4Wk8ayh+5BPw6BofPG9U2hiRI8j8MvSOTKIak8AT/T2IMNJgEuRiCinMFeY
UserID- iruser
Password- IR@1234
after login please click on Tab 'Unit 101' it will take around 5-6 sec to load ext.net Page. this page is working fine in Firefox/chrome.

geoffrey.mcgill
Feb 24, 2014, 12:47 PM
Login credentials failed. I wasn't able to login.

Vladimir
Feb 24, 2014, 12:49 PM
Unfortunatelly, creadentials are invalid, i cannot login to your application

aditya
Feb 24, 2014, 12:49 PM
Login credentials failed. I wasn't able to login.
Hi @geoffrey,
sorry for wrong credentials. it was misspelled. i corrected it please check again with
UserID- iruser
Password- IR@1234

Vladimir
Feb 24, 2014, 2:04 PM
I guess that you use dynamic compression in IIS 7.5
Ext.Net compress own resources also. So, i think it is root of IE issues (double compression)

Please deactivate IIS compression module for ext.axd paths or deactivate Ext.Net compression (GZip="false" for ResourceManager or in web.config in extnet section)

aditya
Feb 25, 2014, 3:53 AM
I guess that you use dynamic compression in IIS 7.5
Ext.Net compress own resources also. So, i think it is root of IE issues (double compression)

Please deactivate IIS compression module for ext.axd paths or deactivate Ext.Net compression (GZip="false" for ResourceManager or in web.config in extnet section)

Hi @Vladimir thanks for reply.
I try as you say but still getting error.

Vladimir
Feb 25, 2014, 10:55 AM
Can you describe what did you try? Did you try to deactivate IIS compression?

aditya
Feb 25, 2014, 1:11 PM
Can you describe what did you try? Did you try to deactivate IIS compression?
i used this line in my page

<ext:ResourceManager ID="ResourceManager1" runat="server" GZip="false"/>

Vladimir
Feb 25, 2014, 2:24 PM
Well, I guess it is better to set it in web.config. In this case, Ext.Net handler will able to read it.
So,
- try to set the setting in web.config (please ensure that extnet section is properly configured in web.config, see http://examples2.ext.net/#/Getting_Started/Introduction/Overview/)


<extnet gzip="false" />


- if web.config setting doesn't help you then deactivate IIS compression

Please note, browser caches ext.net resource, so you need to clear cache before testing

aditya
Feb 26, 2014, 3:55 AM
Well, I guess it is better to set it in web.config. In this case, Ext.Net handler will able to read it.
So,
- try to set the setting in web.config (please ensure that extnet section is properly configured in web.config, see http://examples2.ext.net/#/Getting_Started/Introduction/Overview/)


<extnet gzip="false" />


- if web.config setting doesn't help you then deactivate IIS compression

Please note, browser caches ext.net resource, so you need to clear cache before testing

thanks a lot @Vladimir, finally it works. Can you suggest me where i can find list of attribute of <extnet> tag in webconfig. like gzip="false".
please close this issue.

geoffrey.mcgill
Feb 26, 2014, 4:06 AM
thanks a lot @Vladimir, finally it works. Can you suggest me where i can find list of attribute of <extnet> tag in webconfig. like gzip="false".

Please see section "V. <extnet> WEB.CONFIG GLOBAL CONFIGURATION PROPERTIES" of the README.txt.

http://examples2.ext.net/#/Getting_Started/Release_Documents/README/

Hope this helps.

aditya
Feb 26, 2014, 7:29 AM
Please see section "V. <extnet> WEB.CONFIG GLOBAL CONFIGURATION PROPERTIES" of the README.txt.

http://examples2.ext.net/#/Getting_Started/Release_Documents/README/

Hope this helps.

Thanks @geoffrey for quick responce. This link helped me a lot. You guys are great . Please close this thread.