PDA

View Full Version : [CLOSED] Multiupload ErrorCode



vzx
Dec 25, 2013, 3:55 PM
Hi all,

I got exactly the same error. (http://forums.ext.net/showthread.php?27314-CLOSED-Multiupload-error-code)


Please try the following.

1. Set up FormID="Form1" for the MultiUpload. It requires updating for the SVN trunk.

2. Set up DisableViewState="false" for the ResourceManager.

Does it help remedy the issue?

Unfortunately, this is not solved my issue. Can you suggest any other way?

Thanks,

Vzx

Vladimir
Dec 25, 2013, 4:07 PM
Did you update from SVN first?
Just to ensure that your version of MultiUpload has FormID property

vzx
Dec 25, 2013, 4:31 PM
Yes, i have the latest version. MultiUpload has FormID property.

vzx
Dec 25, 2013, 4:35 PM
The code is below;


<%@ Page Language="C#" %>

<script runat="server">
protected void MultiUpload1_FileUpload(object sender, FileUploadEventArgs e)
{
System.Threading.Thread.Sleep(3000); // for testing purposing only
X.Msg.Notify("File is uploaded", "Name: " + e.FileName).Show();
}
</script>

<!DOCTYPE html>

<html>
<head runat="server">
<title>Simple MultiUpload - Ext.NET Examples</title>
<link href="/resources/css/examples.css" rel="stylesheet" />
<script type="text/javascript">
var uploadError = function (item, file, errorCode, message) {
alert("Error Code: " + errorCode + ", File name: " + file.name + ", File size: " + file.size + ", Message: " + message);
};

var fileSelectionError = function (item, file, errorCode, message) {
alert("Error Code: " + errorCode + ", File name: " + file.name + ", File size: " + file.size + ", Message: " + message);
};
</script>
</head>
<body>
<form runat="server" id="Form1">
<ext:ResourceManager runat="server" DisableViewState="false" />

<h1>Simple MultiUpload</h1>

<ext:MultiUpload
ID="MultiUpload1"
runat="server"
OnFileUpload="MultiUpload1_FileUpload"
AutoStartUpload="true"
FileDropAnywhere="true"
FileSizeLimit="15 MB"
FileTypes="*.*"
FormID="Form1"
FileTypesDescription="All Files"
FileUploadLimit="100"
FileQueueLimit="0">
<Listeners>
<UploadStart Handler="Ext.Msg.wait('Uploading...');" />
<UploadError Fn="uploadError" />
<FileSelectionError Fn="fileSelectionError" />
<UploadComplete Handler="Ext.Msg.hide();" />
</Listeners>
</ext:MultiUpload>
</form>
</body>
</html>

Vladimir
Dec 25, 2013, 5:42 PM
What about to deactivate viewstate for flash request, like the following


MultiUpload1.PostParams.Add(new Ext.Net.Parameter("__VIEWSTATE", ""));

vzx
Dec 25, 2013, 6:01 PM
What about to deactivate viewstate for flash request, like the following


MultiUpload1.PostParams.Add(new Ext.Net.Parameter("__VIEWSTATE", ""));


This solved my problem. Thank you Vladimir.

stebag
Apr 30, 2014, 5:43 AM
Hi.
I noted the _VIESWSTATE solution works only sometimes. For example it work the first time but using the same function a second or a third time the error code appears and the upload fails. Sometime the error is raised on the first attempt too. I tried with different operanting systems (Windows 7, Windows XP), different briwsers (IE, Firefox, Chrome) on different workstations.

Thanks.
Stefano



What about to deactivate viewstate for flash request, like the following


MultiUpload1.PostParams.Add(new Ext.Net.Parameter("__VIEWSTATE", ""));

Vladimir
Apr 30, 2014, 7:09 AM
We will try to reproduce it
Just question, do you need viewstate on that page with multiupload? Is it so required?

stebag
Apr 30, 2014, 11:22 AM
Otherwise (without Viewstate) the error is presented evetytime.

Thanks.
Stefano



We will try to reproduce it
Just question, do you need viewstate on that page with multiupload? Is it so required?

Vladimir
Apr 30, 2014, 12:24 PM
Hi,

I cannot reproduce the issue if __VIEWSTATE parameter is added to PostParams
I cannot reproduce the issue if viewstate is deactivated in ResourceManager (DisableViewState is true)

So, please create new thread and post simple test case reproduces the issue
Discussion in this thread is closed