PDA

View Full Version : [CLOSED] Could not load file or assembly 'System.Web.Mvc, Version=3.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35'



hdsoso
Oct 13, 2013, 2:39 AM
it was ok, but today , i deploy my site , show this error,
Parser Error

Description: An error occurred during the parsing of a resource required to service this request. Please review the following specific parse error details and modify your source file appropriately.

Parser Error Message: Could not load file or assembly 'System.Web.Mvc, Version=3.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35' or one of its dependencies. 系统找不到指定的文件。

may be need mvc 3.0 , but it was ok , i deploy this time with debug mode , is it the reason?

michaeld
Oct 13, 2013, 2:54 AM
http://forums.ext.net/showthread.php?26814-SVN-update-missing-Reference-System-Web-Mvc

hdsoso
Oct 13, 2013, 3:12 AM
http://forums.ext.net/showthread.php?26814-SVN-update-missing-Reference-System-Web-Mvc

manually remove mvc reference is little trouble.
may be must install mvc 3 , but i download the installed and installed it, and restart server ,not work.(from http://www.asp.net/mvc/mvc3 this page to install mvc 3, is it ok) , how to distinguish whether installed mvc 3.0 or not?

@michaeld,
my ext.net version is 2.2.0.30029, my last deploy is ok , but this version deployed failed, how do you resolve it?

hdsoso
Oct 13, 2013, 3:41 AM
when i install the AspNetMVC3Setup_CHS.exe
show the message ,
7033

ok , i install AspNetMVC3Setup , now it is ok now, you can close the thread.
thank all who answer me.

Vladimir
Oct 13, 2013, 10:29 AM
Did you build Ext.Net assemblies yourself or use precompiled versions (from Nuget)?
Just update from trunk, open Ext.Net solution, choose "WebForm NET40" mode and rebuild assemblies. Such assemblies will not require installed MVC

hdsoso
Oct 13, 2013, 2:13 PM
Did you build Ext.Net assemblies yourself or use precompiled versions (from Nuget)?
Just update from trunk, open Ext.Net solution, choose "WebForm NET40" mode and rebuild assemblies. Such assemblies will not require installed MVC

here???
7036

michaeld
Oct 14, 2013, 2:47 AM
Go to Configuration Manager and Select WebForm NET 4.0 Debug/Release