PDA

View Full Version : [CLOSED] Disabled buttons look VERY dim...can hardly read text...



rthiney
Sep 14, 2013, 3:17 PM
Used to be able too at least read text on a button. Is there a way to fix this using some global css?

michaeld
Sep 15, 2013, 2:13 AM
I'm just another customer, but I don't think it looks dim at all. To me it looks like there is no text. Do you see text when enable the button?

Daniil
Sep 16, 2013, 6:30 AM
Hi everybody,

Seems I see something in that button. There is some icon, then "Save C...". Indeed, it is very dim.

@rthiney, to help you we have to reproduce it. I am unable to reproduce it running this example with Ext.NET trunk in FireFox.

Example

<%@ Page Language="C#" %>

<%@ Register Assembly="Ext.Net" Namespace="Ext.Net" TagPrefix="ext" %>

<!DOCTYPE html>
<html>
<head runat="server">
<title>Ext.NET v2 Example</title>
</head>
<body>
<form runat="server">
<ext:ResourceManager runat="server" />

<ext:FormPanel runat="server" Width="300">
<Buttons>
<ext:Button runat="server" Text="Button" Disabled="true" />
</Buttons>
</ext:FormPanel>
</form>
</body>
</html>

rthiney
Sep 26, 2013, 2:02 AM
Hi everybody,

Seems I see something in that button. There is some icon, then "Save C...". Indeed, it is very dim.

@rthiney, to help you we have to reproduce it. I am unable to reproduce it running this example with Ext.NET trunk in FireFox.

Example

<%@ Page Language="C#" %>

<%@ Register Assembly="Ext.Net" Namespace="Ext.Net" TagPrefix="ext" %>

<!DOCTYPE html>
<html>
<head runat="server">
<title>Ext.NET v2 Example</title>
</head>
<body>
<form runat="server">
<ext:ResourceManager runat="server" />

<ext:FormPanel runat="server" Width="300">
<Buttons>
<ext:Button runat="server" Text="Button" Disabled="true" />
</Buttons>
</ext:FormPanel>
</form>
</body>
</html>





Here is the markup generated, along with screen shot, IE 10


<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd"><html xmlns="http://www.w3.org/1999/xhtml">
<head>
<link type="text/css" rel="stylesheet" href="/extjs/resources/ext_theme_classic/ext-theme-classic-all-embedded-css/ext.axd?v=30924" id="ext-theme" />
<link type="text/css" rel="stylesheet" href="/extnet/resources/css/extnet-all-embedded-css/ext.axd?v=30924" />
<style type="text/css">
.start-loading-mask{position:absolute;left:0;top:0;width:100%;hei ght:100%;z-index:20000;background-color:#fff}.start-loading{position:absolute;left:50%;top:50%;width:1 40px;height:120px;margin:-60px 0 0 -70px;z-index:20001}.start-loading img{margin-left:20px;width:100px;height:100px}.start-loading .loading-indicator p{color:#555;font:700 13px tahoma,arial,helvetica;padding:10px;margin:0;text-align:center;height:auto}
</style>
<script type="text/javascript" src="/extjs/ext-all-js/ext.axd?v=30924"></script>
<script type="text/javascript" src="/extnet/extnet-all-js/ext.axd?v=30924"></script>


<title></title>

<style type="text/css">
body {
font-family: 'Segoe UI';
}

.panelBackColor {
background-color: #ddeefa;
}
/*.x-toolbar-item.x-btn-group .x-form-trigger
{
height: 21px;
}


.x-border-box .x-toolbar-item.x-btn-group .x-form-trigger
{
height: 22px;
}*/
</style>




<script type="text/javascript">
//<![CDATA[
Ext.net.ResourceMgr.init({"id":"ctl00$Resource1","aspForm":"form1","icons":["Disk"]});Ext.onReady(function(){Ext.create("Ext.button.Button",{"id":"ContentPlaceHolder1_txt","disabled":true,"renderTo":"App.ContentPlaceHolder1_txt_Container","iconCls":"#Disk","text":"Save"});});Ext.onReady(function(){setTimeout(function() {Ext.select('.mask-el').fadeOut({remove:true, duration: 1000});}, 250);});
//]]>
</script>
</head>
<body>
<div class="start-loading-mask mask-el"></div><div class="start-loading mask-el"><div class="loading-indicator"><img src="/extnet/resources/images/start-loading-gif/ext.axd" align="middle" /><p>Welcome to Valuations 2013</p></div></div>


<form method="post" action="WebForm1.aspx" id="form1">
<div class="aspNetHidden">






</div>








<div>

<div id="App.ContentPlaceHolder1_txt_Container"></div>


</div>

</form>

</body>
</html>

Daniil
Sep 26, 2013, 2:18 PM
With Ext.NET from the SVN trunk I am getting the following picture.
6943

What Ext.NET version are you testing with?

Daniil
Oct 03, 2013, 6:06 AM
I think it has been fixed after this bug report:
http://forums.ext.net/showthread.php?25143