PDA

View Full Version : [CLOSED] Ext.net does not support IE9 compatiability view ?



wangyi
Sep 05, 2013, 10:51 AM
Page runs in IE9 and IE8 normaly.

But when I choose the IE compatiability view , the page is blank.

Ext.net does not support IE9 compatiability view ?

Daniil
Sep 05, 2013, 10:59 AM
Hi @wangyi,

Yes, neither Ext.NET nor ExtJS support IE compatibility modes.

jchau
Sep 05, 2013, 2:49 PM
You can force IE out of compatibility mode so even if user selects compatibility mode, Ext.NET still works fine.



Response.AppendHeader("X-UA-Compatible", "IE=Edge")

wangyi
Sep 06, 2013, 3:54 AM
<meta http-equiv="X-UA-Compatible" content="IE=edge"/>

I add the mark. But in IE9 compatiability view, the page is still blank.

Daniil
Sep 06, 2013, 5:54 AM
I doubt these things are the same:

<meta http-equiv="X-UA-Compatible" content="IE=edge" />



and

Response.AppendHeader("X-UA-Compatible", "IE=Edge")

The last one supposes that a user won't be able to switch to the compatibility mode. As far as I can understand it.