PDA

View Full Version : [CLOSED] Checkbox is not getting clear after de-selecting



WHISHWORKS
Jul 17, 2013, 12:54 PM
Hello,

I am using MultiCombo box in my code and when we de-select any of item it is not clearing the checkbox selection. In the older version it was working fine, but in new version of ext.net controls it is not working. I am attaching the sample code and screen shot for the same. Could you please look into this.


<%@ Page Language="C#" AutoEventWireup="true" CodeBehind="Combo.aspx.cs" Inherits="Ext.NetSamples.Combo" %>
<%@ Register Assembly="Ext.Net" Namespace="Ext.Net" TagPrefix="ext" %>
<!DOCTYPE html>

<html>
<head id="Head1" runat="server">
<title>MultiCombo - Ext.NET Examples</title>
<link href="/resources/css/examples.css" rel="stylesheet" />

<script>
var updateButtonText = function (item, checked) {
var text = [];

item.parentMenu.items.each(function (item) {
if (item.checked) {
text.push(item.text);
}
});

if (text.length == 0) {
App.Button1.setText("[Select Colors]");
} else {
App.Button1.setText("[" + text.join(",") + "]");
}
};
</script>
</head>
<body>
<form id="Form1" runat="server">
<ext:ResourceManager runat="server" />

<h2>Simple MultiCombo</h2>

<ext:MultiCombo runat="server" Width="260">
<Items>
<ext:ListItem Text="Item 1" Value="1" />
<ext:ListItem Text="Item 2" Value="2" />
<ext:ListItem Text="Item 3" Value="3" />
<ext:ListItem Text="Item 4" Value="4" />
<ext:ListItem Text="Item 5" Value="5" />
</Items>

<SelectedItems>
<ext:ListItem Value="2" />
<ext:ListItem Index="4" />
</SelectedItems>
</ext:MultiCombo>
<br />


</form>
</body>
</html>

Vladimir
Jul 17, 2013, 1:14 PM
It is already fixed in SVN, please update from SVN (http://svn.ext.net/premium/trunk) and retest

WHISHWORKS
Jul 17, 2013, 4:31 PM
Hello Vladimir ,

Thank you for your quick reply.

I have checkout the source code from the SVN path and I tried to use that in my application and it resolves the checkbox issue but it is disturbing all other controls css (we have done lot of custom css to ext.net controls). We have used the version from ext.net website and UI was working fine only this combo issue. When we compare the both ext.net dlls there is difference in the version i.e. SVN version is 2.2.0.35005 and latest download from ext.net website is 2.2.0.40838.

Could you please confirm which is the latest version.

Daniil
Jul 17, 2013, 4:45 PM
Could you please confirm which is the latest version.

The latest one is the one that you got from SVN trunk.

The last numbers (minor version of dll) depends on time of the build. Here is an explanation.
Version numbers in a compiled assembly (http://blogs.msdn.com/b/carloc/archive/2008/02/22/the-meaning-of-version-numbers-in-a-compiled-assembly.aspx)

If the newest Ext.NET sources breaks your custom CSS, it probably means that you will need to rework the CSS part a bit to get it working again.

I can understand that it can be not an option at the moment. So, you can apply this fix without updating to the trunk.
http://forums.ext.net/showthread.php?24881#post110736

WHISHWORKS
Jul 17, 2013, 5:04 PM
it works fine... thank you Daniil for you help.




The latest one is the one that you got from SVN trunk.

The last numbers (minor version of dll) depends on time of the build. Here is an explanation.
Version numbers in a compiled assembly (http://blogs.msdn.com/b/carloc/archive/2008/02/22/the-meaning-of-version-numbers-in-a-compiled-assembly.aspx)

If the newest Ext.NET sources breaks your custom CSS, it probably means that you will need to rework the CSS part a bit to get it working again.

I can understand that it can be not an option at the moment. So, you can apply this fix without updating to the trunk.
http://forums.ext.net/showthread.php?24881#post110736