PDA

View Full Version : Icon IE 7



Maia
Mar 25, 2009, 11:19 AM
My project uses Desktop. In IE7 the icons of DesktopShortcut not appear.
Ok in FF and Opera it's ok.

Code:


<Shortcuts>
<ext:DesktopShortcut ModuleID="DesktopModule1" Text="Tipos Contatos" IconCls="icon-phone48"/>
<ext:DesktopShortcut ModuleID="DesktopModule2" Text="Prospects" IconCls="icon-factory48"/>
</Shortcuts>


Css:


.icon-factory48
{
width:48px;
height:48px;
background-image: url(../Img/factory_48x48.png) !important;
}
.icon-phone48
{
width:48px;
height:48px;
background-image: url(../Img/phone2_48x48.png) !important;

}

Maia.

yaser82
Mar 25, 2009, 12:45 PM
Hi,

Do you mean that the icons are not appearing at all or just appearing in different way that you have specified? Please check this post, hope it helps :) :

http://forums.ext.net/showthread.php?2480

Maia
Mar 25, 2009, 3:08 PM
The icons are not appearing, only appear the name (text) shortcut .
With FF and Opera it's ok, but IE7 and IE8 no.
I checked the post and changed the CSS, but it did not work.



.icon-factory48
{
width:48px;
height:48px;
background-image: url(../Img/factory_48x48.png) !important;
filter:progid:DXImageTransform.Microsoft.AlphaImag eLoader(src="../Img/factory_48x48.png", sizingMethod="scale");
}

Any tips?
Maia.

Maia
Mar 25, 2009, 5:44 PM
Hi,
I did download the Demo Coolite and it works, but it put the icons in
separate folder does not work. The structure of the folders is as
follows:

Content/img/vista_start_button.gif

I did the following tests:


.start-button {
background-image:url("Content/img/vista_start_button.gif") !important;
}

.start-button {
background-image:url("../Content/img/vista_start_button.gif") !important;
}
.start-button {
background-image:url("/Content/img/vista_start_button.gif") !important;
}
.start-button {

background-image:url("../img/vista_start_button.gif") !important;

}


Any help!
Maia

Maia
Mar 25, 2009, 6:58 PM
Hi,
I put the folder Img in the root and showed the images in IE7, IE8, FF3, Opera.
As a subfolder of the Content does not work in the IE.

The structure of the folders is as

follows:

Img/vista_start_button.gif



.start-button {
background-image:url("/Img/vista_start_button.gif") !important;
}


Thanks.
Maia.

Vladimir
Mar 25, 2009, 8:02 PM
Hi,

If your url starts with / then it is mean web root


Try



background-image:url("Img/vista_start_button.gif") !important;