PDA

View Full Version : [CLOSED] Migrating from 2.1 to 2.2 issue



RCM
May 23, 2013, 4:03 PM
Hi, we curerntly migrated from 2.1 to 2.2 and experiencing lots of javacript errors, which i assume are breaking changes introduced in 2.2, is there any document that addresses what the breaking changes in 2.2 are and how to migrate from 2.1 to 2.2.

For instance, getting error that filterby is not available on grid even when the call is made by ext.js.

Rgards

Vladimir
May 23, 2013, 4:44 PM
What kind of errors do you have?



For instance, getting error that filterby is not available on grid even when the call is made by ext.js.

Grid has no filterby method (and in previous version it has no the method also, filterBy is store javascript method)

RCM
May 23, 2013, 6:04 PM
You never answered my question about the any breaking changes document. The error is everywhere. Group tab panel that works previously in 2.1, no longer works as only the content of teh first tab displays, the other tabs do not display anything.

Please if there is a log file about breaking changes can you provide me with one.

Vladimir
May 23, 2013, 6:17 PM
You never answered my question about the any breaking changes document.

Breaking changes document is always provided with each release. You can find it in SVN also (http://svn.ext.net/premium/branches/2.2/Ext.Net/Build/Ext.Net/BREAKING_CHANGES.txt) or view online
http://examples2.ext.net/#/Getting_Started/Release_Documents/BREAKING_CHANGES/



Group tab panel that works previously in 2.1, no longer works as only the content of teh first tab displays, the other tabs do not display anything.

For me it works fine, please see online sample
http://examples2.ext.net/#/TabPanel/GroupTabPanel/Overview/

If you have a test case with errors then please post it and we will investigate it