PDA

View Full Version : [CLOSED] themePath web.config



Kev
May 16, 2013, 3:52 PM
Hi,
I've downloaded a custom theme and added it to folder in my project. However, when I modify the web.config to include the path to the css file I get the error "Unrecognized attribute 'themePath'. Note that attribute names are case-sensitive." even though I am following the one set out in the Web.config <extnet> Global Configuration Properties.

Here is my web config entry:


<extnet themePath="/Theme/xtheme-yourthemeG/css/xtheme-yourthemeG.css" />

I've also tried most permutations to see if there was a type but to no avail.

Thanks,
Kev

geoffrey.mcgill
May 16, 2013, 4:52 PM
Hello,

Can you confirm that you are using Ext.NET 2.2?

Kev
May 17, 2013, 8:08 AM
Hello,

Can you confirm that you are using Ext.NET 2.2?

I'm using 2.1.1.18167

Daniil
May 17, 2013, 10:22 AM
Hi,

The ThemePath property has been added in v2.2.

Kev
May 17, 2013, 10:38 AM
Hi,

The ThemePath property has been added in v2.2.

Thanks Daniil. What are the options to apply a custom theme in 2.1 to override the built in ones? I've downloaded one from a theme builder site.

Daniil
May 17, 2013, 10:57 AM
You can set up

Theme="None"
for a ResourceManager or

theme="None"
in a Web.config and add a custom theme file to pages as a common CSS file, i.e. via:

<link href="custom-theme.css" rel="stylesheet" />

Kev
May 17, 2013, 11:13 AM
You can set up

Theme="None"
for a ResourceManager or

theme="None"
in a Web.config and add a custom theme file to pages as a common CSS file, i.e. via:

<link href="custom-theme.css" rel="stylesheet" />

Theme="None" in the resource manager or theme="none" isn't a valid enum unfortunately Daniil? I've tried renderstyles="None" though which switches everything off.

Unfortunately, the stylesheet doesn't seem to be picked up correctly - the reference to the file is correct though. I'm using:

http://extbuilder.dynalias.com/springapp/mainpage.htm

Have you used this or is it recommended?

Vladimir
May 17, 2013, 11:19 AM
I'm using:
http://extbuilder.dynalias.com/springapp/mainpage.htm

That theme builder is for ExtJS 3.3, 3.2, 3.1, 3.0, 2.3.

It doesn't compatible with ExtJS 4.x (Ext.Net v2 uses ExtJS v4). Also can be an issues with Ext.Net v1.6 also because v1 uses ExtJS 3.4 (i don't see that the theme builder supports ExtJS 3.4)

Daniil
May 17, 2013, 11:47 AM
Theme="None" in the resource manager or theme="none" isn't a valid enum unfortunately Daniil?

Sorry, it was also added after the v2.1 release.

Yes, RenderStyles="None" can be a solution, but you will also need to add the extnet-all.css file (themed as well).

P.S. Just to clarify. This post doesn't cancel the Vladimir's one, just adds something.

Kev
May 17, 2013, 12:26 PM
That theme builder is for ExtJS 3.3, 3.2, 3.1, 3.0, 2.3.

It doesn't compatible with ExtJS 4.x (Ext.Net v2 uses ExtJS v4). Also can be an issues with Ext.Net v1.6 also because v1 uses ExtJS 3.4 (i don't see that the theme builder supports ExtJS 3.4)

Thanks Daniil, I shall see if I can find a theme builder for ExtJS 3.4.

Daniil
May 17, 2013, 1:11 PM
Thanks Daniil, I shall see if I can find a theme builder for ExtJS 3.4.

If you use Ext.NET v2, that is not an option. v2.1 release uses ExtJS 4.1.1.