PDA

View Full Version : [CLOSED] StartCollapsed not working



JCarlosF
Apr 20, 2013, 4:49 PM
why does not this work:



<Features>
<ext:Grouping ID="Grouping2" runat="server" HideGroupedHeader="True" StartCollapsed="True" GroupByText="Agrupar por"
ShowGroupsText="Mostrar en Grupos" GroupHeaderTplString='{name}' >
</ext:Grouping>
</Features>




assign the attribute StartCollapsed=true but does not work, why?

JCarlosF
Apr 20, 2013, 5:07 PM
why does not this work:



<Features>
<ext:Grouping ID="Grouping2" runat="server" HideGroupedHeader="True" StartCollapsed="True" GroupByText="Agrupar por"
ShowGroupsText="Mostrar en Grupos" GroupHeaderTplString='{name}' >
</ext:Grouping>
</Features>




assign the attribute StartCollapsed=true but does not work, why?

I solved it like this: (codebehind)



Grouping2.CollapseAll()


thanks!

Daniil
Apr 22, 2013, 4:47 AM
Hi @jCarlosF,

Thank you for the report. It is a known issue.
https://github.com/extnet/Ext.NET/issues/26

Daniil
Jun 03, 2013, 3:59 PM
The issue appears to be fixed in SVN. The fix will go to the next release (v2.2.1 or v2.3).

ATLAS
Jun 24, 2013, 12:46 PM
The issue appears to be fixed in SVN. The fix will go to the next release (v2.2.1 or v2.3).

Hi guys,
Is there somewhere I can review the (expected) release dates for such updates? With my Premium licence, can I pick up this change from SVN and build a local copy of Ext.Net? Using http://svn.ext.net/premium/trunk/ only seems to give me v2.2.0.19581

Daniil
Jun 24, 2013, 2:30 PM
Hi @ATLAS,

Welcome to Ext.NET forums!

Unfortunately, no official release date is available at this time.

Yes, you can grab the latest sources from the SVN trunk. To login you should use SVN credentials which should be emailed to you when you bought Premium Support Subscription.

ATLAS
Jun 24, 2013, 2:51 PM
Hi @ATLAS,

Welcome to Ext.NET forums!

Unfortunately, no official release date is available at this time.

Yes, you can grab the latest sources from the SVN trunk. To login you should use SVN credentials which should be emailed to you when you bought Premium Support Subscription.

Forgive the newbie questions but, if I use TortoiseSVN to access http://svn.ext.net/premium/trunk/ and build the VS2012 version, should I pick up this fix? I'm confused because the DLL versioning seems to show v2.2.0.19581 and not 2.2.1 as I expected.

It would be useful not to close a post until the user has had all questions answered!

Daniil
Jun 24, 2013, 3:48 PM
Forgive the newbie questions but, if I use TortoiseSVN to access http://svn.ext.net/premium/trunk/ and build the VS2012 version, should I pick up this fix? I'm confused because the DLL versioning seems to show v2.2.0.19581 and not 2.2.1 as I expected.


Yes, the SVN trunk sources contains that fix. Please do not worry about the version. We commonly update it just before the release.


It would be useful not to close a post until the user has had all questions answered!

Do you mean [CLOSED] in the thread's title? Well, it was marked as closed April 22, quite long ago your question. Anyway, sorry for the confusion, I thought that mentioning "you can grab the latest sources from the SVN trunk" answers your question.

ATLAS
Jun 24, 2013, 3:53 PM
Yes, the SVN trunk sources contains that fix. Please do not worry about the version. We commonly update it just before the release.



Do you mean [CLOSED] in the thread's title? Well, it was marked as closed April 22, quite long ago your question. Anyway, sorry for the confusion, I thought that mentioning "you can grab the latest sources from the SVN trunk" answers your question.

I'll give that a try. Sorry for my confusion over the closed thread status.

Daniil
Jun 24, 2013, 4:01 PM
Not problem. Please confirm if the issue is going away with the update or not.

I have removed [CLOSED] label for now.

ATLAS
Jun 24, 2013, 4:18 PM
Not problem. Please confirm if the issue is going away with the update or not.

I have removed [CLOSED] label for now.

That works correctly now. Thanks. You can close the thread ;-)