PDA

View Full Version : [CLOSED] Panel + BottomBar + Toolbar



Zarzand
Mar 19, 2009, 5:21 PM
Hi Coolite Team,

I think I found a bug when I put a ToolBar in Panel -> BottomBar it shows on top and then when you move your mouse over it just move it bottom. This only happens in IE.... Firefox is fine.




<Coolite:ViewPort ID="WebManagementViewPort" runat="server">
<Body>
<Coolite:BorderLayout ID="WebManagementBorderLayout" runat="server">
<Center MarginsSummary="5 5 5 5">
<Coolite:Panel ID="pnlCenter" runat="server" Title="Search" Frame="true">
<BottomBar>
<Coolite:Toolbar ID="tlbSearch" runat="server">
<Items>
<Coolite:ToolbarFill runat="server"></Coolite:ToolbarFill>
<Coolite:ComboBox ID="cmbRecords" runat="server" Title="Record" Editable="false" Width="50">
<Items>
<Coolite:ListItem Value="25" Text="25" />
<Coolite:ListItem Value="50" Text="50" />
<Coolite:ListItem Value="100" Text="100" />
<Coolite:ListItem Value="250" Text="250" />
<Coolite:ListItem Value="500" Text="500" />
</Items>
</Coolite:ComboBox>
<Coolite:Button ID="btnSearch" runat="server" Text="Search" Icon="Find">
</Coolite:Button>
</Items>
</Coolite:Toolbar>
</BottomBar>
<Body>
adfasdfasdfasfdasd
</Body>
</Coolite:Panel>
</Center>
</Coolite:BorderLayout>
</Body>
</Coolite:ViewPort>

Vladimir
Mar 19, 2009, 5:31 PM
Hi,

I can't reproduce this bug under IE.


Can you try add one of the following listeners to ViewPort (please update from SVN first because we added listeners to ViewPort recently)


               <Listeners>
                    <Render Handler="this.doLayout();" Delay="100" />
                </Listeners>


               <Listeners>
                    <Render Handler="this.el.repaint();" Delay="100" />
                </Listeners>

Zarzand
Mar 19, 2009, 6:32 PM
Thanks this worked...