PDA

View Full Version : [CLOSED] Razor combobox edit showing id's



OriCoder
Apr 01, 2013, 10:53 PM
Hi

Have comboboxes on my grid panel and when first entering I just get the id but the drop down is working fine and the renderer on the column gives me the values I expect. Just that on edit I get the id.... Any idea what I could be missing?

Baidaly
Apr 01, 2013, 11:38 PM
Hello!

It's difficult to something concrete without a sample. However, maybe this example will be helpful: http://mvc.ext.net/#/GridPanel_Data_Presentation/Editor_Field_Mapping/

OriCoder
Apr 02, 2013, 11:17 AM
Hello!

It's difficult to something concrete without a sample. However, maybe this example will be helpful: http://mvc.ext.net/#/GridPanel_Data_Presentation/Editor_Field_Mapping/

Yes this is what I have except that my data is coming from a proxy for the dropdown check the setting and all looks to be the same as the example. Can't really pull out an example from the code as its to intagrated.

any Ideas why when I go to edit I get say 1 instead of "Department A"

Daniil
Apr 02, 2013, 11:22 AM
Please try to debug the Renderer. Maybe, it will give a clue.

Maybe, the Store which provides the descriptions is not loaded yet when the GridPanel is rendered?

OriCoder
Apr 02, 2013, 2:05 PM
Store is loaded as the descriptions are rendered correctly when the grid loads and the renderder is applied there.

Any tips for debuging the renderer my firebug foo is a bit weak.

Daniil
Apr 02, 2013, 2:19 PM
Using a "debugger" statement can help to debug.

If the issue persists, please provide a sample to reproduce the problem.

OriCoder
Apr 02, 2013, 2:21 PM
will do thanks, will get back with the results