PDA

View Full Version : [CLOSED] InputMask JS error



stratadev
Mar 13, 2013, 2:08 PM
Hi, I'm using ExtJS version 4.2.0.489 and Ext.net version 2.1.0. The code below throws a javascript error. I'm using IE 9 standards.

JS error: "Unable to set value of the property 'inputMask': object is null or undefined"


<html>
<head id="Head1" runat="server">
<title>Test Page </title>
<style type="text/css">

</style>
</head>
<body>
<script type="text/javascript">

</script>
<form id="Form1" runat="server">
<ext:ResourceManager ID="ResourceManager1" runat="server" ScriptMode="Debug" Theme="Gray"
DisableViewState="true" />
<ext:Panel runat="server" Layout="FitLayout" Height="500" Width="500">
<Items>
<ext:TextField ID="TextField1" runat="server" Note="(999) 999-9999" FieldLabel="Phone">
<Plugins>
<ext:InputMask ID="InputMask1" runat="server" Mask="(999) 999-9999" />
</Plugins>
</ext:TextField>
</Items>
</ext:Panel>
</form>
</body>
</html>

Daniil
Mar 13, 2013, 3:02 PM
Hi @stratadev,

Your sample appears to be working fine with the SVN trunk. Please update.

stratadev
Mar 13, 2013, 4:07 PM
Hi Daniil, thanks for your reply. What ExtJS version is in the trunk? I looked at examples.ext.net and it seems like it is using 4.1.0. But I am using 4.2.0.489. Ext.AbstractComponent is causing the problem because they are different in the constructPlugin method.

Daniil
Mar 13, 2013, 4:27 PM
Currently, there is ExtJS 4.2.0 RC (which is publicly available to download) in the trunk.

Current online Examples Explorer uses ExtJS 4.1.1 which is a base of the last public Ext.NET release v2.1.1.