PDA

View Full Version : [CLOSED] Gap between FieldContainer and HtmlEditor during hBox Layout



Svr77
Mar 10, 2013, 12:28 PM
Hello,

I have a very simple layout like this:


<ext:FieldSet ID="FieldSet1" runat="server" Height="200" Title="<%# SR.GeneralInformation %>" Layout="VBoxLayout" >
<LayoutConfig>
<ext:VBoxLayoutConfig Align="Stretch" />
</LayoutConfig>
<Items>
<ext:FieldContainer ID="FieldContainer1" runat="server" HideLabel="true" CombineErrors="true" MsgTarget="None" Layout="HBoxLayout">
<Defaults>
<ext:Parameter Name="labelAlign" Value="top" Mode="Value" />
<ext:Parameter Name="allowBlank" Value="false" Mode="Raw" />
</Defaults>
<Items>
<ext:TextField ID="Title" runat="server" FieldLabel="<%# TenderResource.TenderTitle %>"
Text="<%# Model.Title %>" AutoDataBind="true" Flex="1" />
<ext:TextField ID="TenderNumber" runat="server" FieldLabel="<%# TenderResource.TenderNumber %>"
Text="<%# Model.TenderNumber %>" AutoDataBind="true" Width="120" Margins="0 5 0 5" />
<ext:TextField ID="InternalTitle" runat="server" FieldLabel="<%# TenderResource.InternalMemo %>"
Text="<%# Model.InternalTitle %>" AutoDataBind="true" Width="160" />
</Items>
</ext:FieldContainer>
<ext:HtmlEditor ID="Description" Flex="1" runat="server" FieldLabel="<%# TenderResource.TenderDescription %>"
Value="<%# Model.Description %>" AutoDataBind="true" EscapeValue="true" LabelAlign="Top" >
</ext:HtmlEditor>
</Items>
</ext:FieldSet>


It is working fine expect of one aspect. Every time when I try to run this form, I see small gap between field container and html editor.
5788
I think this is somehow related with indicators, because when I try to click on the first field and then click on html editor, the first field shows that it should be filled in but the gap is disappears
5789

What should I do in order to remove this gap?

Thanks,
Alexander

Vladimir
Mar 10, 2013, 4:00 PM
Hi,

VBox layout requires Height or Flex property for each item, try to set Height for FieldContainer