PDA

View Full Version : [CLOSED] .NET 4.0 version of the Ext.NET.dll of NuGet package 2.1.1 doesn't contain .MVC namespace



SandorD
Jan 11, 2013, 4:47 PM
I just installed the 2.1.1 NuGet package of Ext.NET and I found that the .NET 4.0 version of the dll does not contain the Ext.Net.MVC namespace. The .NET 3.5 version of the dll does contain the MVC namespace though.

I guess this is not supposed to be the case, especially because the 2.1.0 NuGet package version has the MVC namespace in both the .NET 3.5 and 4.0 versions.

Baidaly
Jan 11, 2013, 9:50 PM
I just installed the 2.1.1 NuGet package of Ext.NET and I found that the .NET 4.0 version of the dll does not contain the Ext.Net.MVC namespace. The .NET 3.5 version of the dll does contain the MVC namespace though.

I guess this is not supposed to be the case, especially because the 2.1.0 NuGet package version has the MVC namespace in both the .NET 3.5 and 4.0 versions.

Hello!

One of the purposes of Ext.NET 2.1.1 was to make two separate versions of Ext.NET: for ASP and for MVC. We will prepare NuGet package for MVC soon. For now, you can download MVC version of Ext.NET on this page: http://www.ext.net/download/

SandorD
Jan 12, 2013, 12:18 AM
Thanks, that will help me for now. But how will this be with 2.1.2? In 2.1.1 it is confusing, the way it is now.

Baidaly
Jan 12, 2013, 1:03 AM
In the future releases versions for ASP.NET and for MVC will be separate. As I said there will be special NuGet package for MVC.

Daniil
Jan 14, 2013, 7:24 AM
with 2.1.2?

Just to clarify. The next public release will be 2.2.0.