PDA

View Full Version : [CLOSED] DirectRequestModule problem when switching to svn dll



zwf
Sep 13, 2012, 11:57 AM
Hi there,

I just switched to the svn dll, which I did in excluding the nuget
ext management and adding the newly compiled dll to the project.
So I had a running application before, so the config was fine.
After the dll change I get this and it is definitely there in the
web.config ???????



The web.config file for this project is missing the required DirectRequestModule.

Example

<system.web>
<httpModules>
<add name="DirectRequestModule" type="Ext.Net.DirectRequestModule, Ext.Net" />
</httpModules>
</system.web>

More information available at "Getting Started".

Am I missing sth. ?

Regards,
Holger

PS: ext.net trunk from svn, VS2012 Win7 64, MVC4, Razor

Daniil
Sep 13, 2012, 2:03 PM
Hi @zwf,

Please clarify is this thing in Web.config? Could you demonstrate your Web.config?


ext.net trunk from svn

We would recommend to update from the 2.1 branch.
http://svn.ext.net/premium/branches/2.1/

Currently, there are the latest sources, not in trunk.

zwf
Sep 13, 2012, 2:06 PM
Hi,
web.config in the view folder.
I'm just tryin the 2.1 branch.


<?xml version="1.0"?>

<configuration>
<configSections>
<sectionGroup name="system.web.webPages.razor" type="System.Web.WebPages.Razor.Configuration.RazorWebSe ctionGroup, System.Web.WebPages.Razor, Version=2.0.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35">
<section name="host" type="System.Web.WebPages.Razor.Configuration.HostSectio n, System.Web.WebPages.Razor, Version=2.0.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" requirePermission="false" />
<section name="pages" type="System.Web.WebPages.Razor.Configuration.RazorPages Section, System.Web.WebPages.Razor, Version=2.0.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" requirePermission="false" />
</sectionGroup>
</configSections>

<system.web.webPages.razor>
<host factoryType="System.Web.Mvc.MvcWebRazorHostFactory, System.Web.Mvc, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" />
<pages pageBaseType="System.Web.Mvc.WebViewPage">
<namespaces>
<add namespace="System.Web.Mvc" />
<add namespace="System.Web.Mvc.Ajax" />
<add namespace="System.Web.Mvc.Html" />
<add namespace="System.Web.Optimization"/>
<add namespace="System.Web.Routing" />
<add namespace="Ext.Net" />
<add namespace="Ext.Net.MVC" />
</namespaces>
</pages>
</system.web.webPages.razor>

<appSettings>
<add key="webpages:Enabled" value="false" />
</appSettings>

<system.web>
<httpHandlers>
<add path="*" verb="*" type="System.Web.HttpNotFoundHandler"/>
<add path="*/ext.axd" verb="*" type="Ext.Net.ResourceHandler" validate="false"/>
</httpHandlers>
<httpModules>
<add name="DirectRequestModule" type="Ext.Net.DirectRequestModule, Ext.Net"/>
</httpModules>

<!--
Enabling request validation in view pages would cause validation to occur
after the input has already been processed by the controller. By default
MVC performs request validation before a controller processes the input.
To change this behavior apply the ValidateInputAttribute to a
controller or action.
-->
<pages
validateRequest="false"
pageParserFilterType="System.Web.Mvc.ViewTypeParserFilter, System.Web.Mvc, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35"
pageBaseType="System.Web.Mvc.ViewPage, System.Web.Mvc, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35"
userControlBaseType="System.Web.Mvc.ViewUserControl, System.Web.Mvc, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35">
<controls>
<add assembly="System.Web.Mvc, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" namespace="System.Web.Mvc" tagPrefix="mvc" />
</controls>
</pages>
</system.web>

<system.webServer>
<validation validateIntegratedModeConfiguration="false" />

<handlers>
<remove name="BlockViewHandler"/>
<add name="BlockViewHandler" path="*" verb="*" preCondition="integratedMode" type="System.Web.HttpNotFoundHandler" />
</handlers>
</system.webServer>
</configuration>


Regards,
Holger

Vladimir
Sep 13, 2012, 2:15 PM
Do you use IIS7?

Daniil
Sep 13, 2012, 5:34 PM
Vladimir means that if you use IIS 7, then you should add this into <system.webServer> section.


<modules>
<add
name="DirectRequestModule"
preCondition="managedHandler"
type="Ext.Net.DirectRequestModule, Ext.Net"
/>
</modules>

As demonstrated here:
http://examples2.ext.net/#/Getting_Started/Release_Documents/README/

zwf
Sep 14, 2012, 1:36 PM
btw. I'm using IIS Express shipped with VS2012.


as mentioned above.

The problem with

DirectRequestModule

is gone, but when I start my app I get the above error.

It's
parameter item shouldn't be null and ArrayTypeMismatchException


UrlHelper urlHelper = new UrlHelper(viewContext.RequestContext, RouteTable.Routes);

in



public static string BuildProxy(ViewContext viewContext)
{
Dictionary<string, Dictionary<string, List<MvcDirectMethod>>> methods = MvcDirectMethod.GetGroupedMethods(viewContext);
StringBuilder sb = new StringBuilder(256);

UrlHelper urlHelper = new UrlHelper(viewContext.RequestContext, RouteTable.Routes);

foreach (KeyValuePair<string, Dictionary<string, List<MvcDirectMethod>>> ns in methods)
{
string nsName = ns.Key;

sb.AppendFormat("Ext.ns(\"{0}\");", nsName);

Dictionary<string, List<MvcDirectMethod>> scopes = ns.Value;

sb.Append("Ext.apply(".ConcatWith(nsName, ", { "));

foreach (KeyValuePair<string, List<MvcDirectMethod>> scope in scopes)
{
string scopeName = scope.Key;
List<MvcDirectMethod> directMethods = scope.Value;
.......

in MvcDirectMethod.cs package Ext.Net.MVC


Regards,
Holger

Vladimir
Sep 14, 2012, 1:43 PM
Can you provide a sample to reproduce that exception?

zwf
Sep 14, 2012, 1:49 PM
Or a FTP to upload.
Use itreppert@itreppert.de
It's about 13 MB compressed with ARC

zwf
Sep 17, 2012, 9:32 AM
So,

I tested the project under VS2010 Ultimate and it works with
the svn version.
No way getting it to work under VS2012.
It works fine with the trunk version, so sth. seems to have been
gone wrong......
Would be nice to have a version that works with VS2012 again.

Regards,
Holger

Daniil
Sep 17, 2012, 9:43 AM
Hi Holger,

Please clarify did correction "assemblyBinding" not help?

Vladimir
Sep 17, 2012, 11:29 AM
Did you receive my email? I sent it in weekend

zwf
Sep 17, 2012, 12:42 PM
No.

I made all the changes, suggested. Then I get this :

4785

And when I add Ext.Net.Utilities in web.config like that :


<runtime>
<assemblyBinding xmlns="urn:schemas-microsoft-com:asm.v1">
<dependentAssembly>
<assemblyIdentity name="System.Web.Helpers" publicKeyToken="31bf3856ad364e35" />
<bindingRedirect oldVersion="1.0.0.0" newVersion="2.0.0.0" />
<assemblyIdentity name="Ext.Net.Utilities" publicKeyToken="2c34ac34702a3c23" />
<bindingRedirect oldVersion="0.0.0-2.0.0" newVersion="2.0.1" />
</dependentAssembly>
<dependentAssembly>
<assemblyIdentity name="System.Web.Mvc" publicKeyToken="31bf3856ad364e35" />
<bindingRedirect oldVersion="1.0.0.0-3.0.0.0" newVersion="4.0.0.0" />
</dependentAssembly>
<dependentAssembly>
<assemblyIdentity name="System.Web.WebPages" publicKeyToken="31bf3856ad364e35" />
<bindingRedirect oldVersion="1.0.0.0" newVersion="2.0.0.0" />
</dependentAssembly>
</assemblyBinding>
</runtime>

then I get this :
4786


I included the compiled dlls from svn :

Ext.Net
Ext.Net.Utilities
Newtonsoft.Json
and
Transformer.NET

The only thing that I added in index.cshtml is :

@Html.X().ResourceManager()
@Html.X().DatePicker()


My question is, did you get Ext.Net running in VS2012 ?
Or should I permanently switch to VS2010 ?

Regards,
Holger

Vladimir
Sep 17, 2012, 12:57 PM
I sent you the following email about your test project


I tested your sample:
- your web.config contains incorrect assembly bindings, please use the following <runtime>
<assemblyBinding xmlns="urn:schemas-microsoft-com:asm.v1">
<dependentAssembly>
<assemblyIdentity name="System.Web.Mvc" publicKeyToken="31bf3856ad364e35" />
<bindingRedirect oldVersion="1.0.0.0-3.0.0.0" newVersion="4.0.0.0" />
</dependentAssembly>
<dependentAssembly>
<assemblyIdentity name="System.Web.WebPages" publicKeyToken="31bf3856ad364e35" />
<bindingRedirect oldVersion="1.0.0.0" newVersion="2.0.0.0" />
</dependentAssembly>
<dependentAssembly>
<assemblyIdentity name="System.Web.Helpers" publicKeyToken="31bf3856ad364e35" />
<bindingRedirect oldVersion="1.0.0.0" newVersion="2.0.0.0" />
</dependentAssembly>
</assemblyBinding>
</runtime>

- Index.cshtml in Home
line 181 //.AlignTo("txtFieldNachname")
line 566 //.ApplyStyles("font-size: 9px;")

you call javascript methods but that methods must be used after controls rendering
line 181 //.AlignTo("txtFieldNachname") - remove that line, just place the button after txtFieldNachname in Items collection
line 566 //.ApplyStyles("font-size: 9px;") - replace by StyleSpec

- remove ResourceManager from buttons.cshtml because it is partial view



So, your web.config assembly binding is incorrect. Each assemblyIdentity and bindingRedirect must be in separate assemblyBinding (see web.config in my above quote )
Just move Ext.Net.Utilities to separate assemblyBinding

zwf
Sep 17, 2012, 1:29 PM
Did you receive my email? I sent it in weekend
Yes, I changed it
With the result above, the first picture.

Vladimir
Sep 17, 2012, 1:33 PM
Please clarify, web.config in the following post is current or before changes
http://forums.ext.net/showthread.php?21005-DirectRequestModule-problem-when-switching-to-svn-dll&p=90862&viewfull=1#post90862

Can you post current web.config (from root folder and from views folder)?

zwf
Sep 17, 2012, 1:35 PM
Root web.config:

<?xml version="1.0" encoding="utf-8"?>
<!--
For more information on how to configure your ASP.NET application, please visit
http://go.microsoft.com/fwlink/?LinkId=169433
-->
<configuration>
<configSections>
<!-- For more information on Entity Framework configuration, visit http://go.microsoft.com/fwlink/?LinkID=237468 -->
<section name="entityFramework" type="System.Data.Entity.Internal.ConfigFile.EntityFrame workSection, EntityFramework, Version=5.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" requirePermission="false" />
</configSections>
<connectionStrings>
<add name="DefaultConnection" providerName="System.Data.SqlClient" connectionString="Data Source=(LocalDb)\v11.0;Initial Catalog=aspnet-KRep-20120915104448;Integrated Security=SSPI;AttachDBFilename=|DataDirectory|\asp net-KRep-20120915104448.mdf" />
</connectionStrings>
<appSettings>
<add key="aspnet:UseTaskFriendlySynchronizationContext" value="true" />
<add key="webpages:Version" value="2.0.0.0" />
<add key="webpages:Enabled" value="false" />
<add key="PreserveLoginUrl" value="true" />
<add key="ClientValidationEnabled" value="true" />
<add key="UnobtrusiveJavaScriptEnabled" value="true" />
</appSettings>
<system.web>
<httpModules>
<add name="DirectRequestModule" type="Ext.Net.DirectRequestModule, Ext.Net"/>
</httpModules>
<httpHandlers>
<add path="*/ext.axd" verb="*" type="Ext.Net.ResourceHandler" validate="false" />
</httpHandlers>
<compilation debug="true" targetFramework="4.5" >
<assemblies>
<add assembly="Ext.Net" />
</assemblies>
</compilation>
<httpRuntime requestValidationMode="4.5" targetFramework="4.5" encoderType="System.Web.Security.AntiXss.AntiXssEncoder, System.Web, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a" />
<machineKey compatibilityMode="Framework45" />
<authentication mode="Forms">
<forms loginUrl="~/Account/Login" timeout="2880" />
</authentication>
<pages>
<namespaces>
<add namespace="System.Web.Helpers" />
<add namespace="System.Web.Mvc" />
<add namespace="System.Web.Mvc.Ajax" />
<add namespace="System.Web.Mvc.Html" />
<add namespace="System.Web.Optimization" />
<add namespace="System.Web.Routing" />
<add namespace="System.Web.WebPages" />
<add namespace="Ext.Net" />
<add namespace="Ext.Net.MVC" />
</namespaces>
</pages>
<profile defaultProvider="DefaultProfileProvider">
<providers>
<add name="DefaultProfileProvider" type="System.Web.Providers.DefaultProfileProvider, System.Web.Providers, Version=1.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" connectionStringName="DefaultConnection" applicationName="/" />
</providers>
</profile>
<membership defaultProvider="DefaultMembershipProvider">
<providers>
<add name="DefaultMembershipProvider" type="System.Web.Providers.DefaultMembershipProvider, System.Web.Providers, Version=1.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" connectionStringName="DefaultConnection" enablePasswordRetrieval="false" enablePasswordReset="true" requiresQuestionAndAnswer="false" requiresUniqueEmail="false" maxInvalidPasswordAttempts="5" minRequiredPasswordLength="6" minRequiredNonalphanumericCharacters="0" passwordAttemptWindow="10" applicationName="/" />
</providers>
</membership>
<roleManager defaultProvider="DefaultRoleProvider">
<providers>
<add name="DefaultRoleProvider" type="System.Web.Providers.DefaultRoleProvider, System.Web.Providers, Version=1.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" connectionStringName="DefaultConnection" applicationName="/" />
</providers>
</roleManager>
<sessionState mode="InProc" customProvider="DefaultSessionProvider">
<providers>
<add name="DefaultSessionProvider" type="System.Web.Providers.DefaultSessionStateProvider, System.Web.Providers, Version=1.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" connectionStringName="DefaultConnection" />
</providers>
</sessionState>
</system.web>
<system.webServer>
<validation validateIntegratedModeConfiguration="false" />
</system.webServer>
<runtime>
<assemblyBinding xmlns="urn:schemas-microsoft-com:asm.v1">
<dependentAssembly>
<assemblyIdentity name="System.Web.Helpers" publicKeyToken="31bf3856ad364e35" />
<bindingRedirect oldVersion="1.0.0.0" newVersion="2.0.0.0" />
</dependentAssembly>
<dependentAssembly>
<assemblyIdentity name="Ext.Net.Utilities" publicKeyToken="2c34ac34702a3c23" />
<bindingRedirect oldVersion="0.0.0-2.0.0" newVersion="2.0.1" />
</dependentAssembly>
<dependentAssembly>
<assemblyIdentity name="System.Web.Mvc" publicKeyToken="31bf3856ad364e35" />
<bindingRedirect oldVersion="1.0.0.0-3.0.0.0" newVersion="4.0.0.0" />
</dependentAssembly>
<dependentAssembly>
<assemblyIdentity name="System.Web.WebPages" publicKeyToken="31bf3856ad364e35" />
<bindingRedirect oldVersion="1.0.0.0" newVersion="2.0.0.0" />
</dependentAssembly>
</assemblyBinding>
</runtime>
<entityFramework>
<defaultConnectionFactory type="System.Data.Entity.Infrastructure.SqlConnectionFac tory, EntityFramework" />
</entityFramework>
</configuration>

views folder config :

<?xml version="1.0"?>

<configuration>
<configSections>
<sectionGroup name="system.web.webPages.razor" type="System.Web.WebPages.Razor.Configuration.RazorWebSe ctionGroup, System.Web.WebPages.Razor, Version=2.0.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35">
<section name="host" type="System.Web.WebPages.Razor.Configuration.HostSectio n, System.Web.WebPages.Razor, Version=2.0.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" requirePermission="false" />
<section name="pages" type="System.Web.WebPages.Razor.Configuration.RazorPages Section, System.Web.WebPages.Razor, Version=2.0.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" requirePermission="false" />
</sectionGroup>
</configSections>

<system.web.webPages.razor>
<host factoryType="System.Web.Mvc.MvcWebRazorHostFactory, System.Web.Mvc, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" />
<pages pageBaseType="System.Web.Mvc.WebViewPage">
<namespaces>
<add namespace="System.Web.Mvc" />
<add namespace="System.Web.Mvc.Ajax" />
<add namespace="System.Web.Mvc.Html" />
<add namespace="System.Web.Optimization"/>
<add namespace="System.Web.Routing" />
<add namespace="Ext.Net" />
<add namespace="Ext.Net.MVC" />
</namespaces>
</pages>
</system.web.webPages.razor>

<appSettings>
<add key="webpages:Enabled" value="false" />
</appSettings>

<system.web>
<httpHandlers>
<add path="*" verb="*" type="System.Web.HttpNotFoundHandler"/>
<add path="*/ext.axd" verb="*" type="Ext.Net.ResourceHandler" validate="false"/>
</httpHandlers>
<httpModules>
<add name="DirectRequestModule" type="Ext.Net.DirectRequestModule, Ext.Net"/>
</httpModules>


<!--
Enabling request validation in view pages would cause validation to occur
after the input has already been processed by the controller. By default
MVC performs request validation before a controller processes the input.
To change this behavior apply the ValidateInputAttribute to a
controller or action.
-->
<pages
validateRequest="false"
pageParserFilterType="System.Web.Mvc.ViewTypeParserFilter, System.Web.Mvc, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35"
pageBaseType="System.Web.Mvc.ViewPage, System.Web.Mvc, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35"
userControlBaseType="System.Web.Mvc.ViewUserControl, System.Web.Mvc, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35">
<controls>
<add assembly="System.Web.Mvc, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" namespace="System.Web.Mvc" tagPrefix="mvc" />
</controls>
</pages>
</system.web>

<system.webServer>
<validation validateIntegratedModeConfiguration="false" />

<handlers>
<remove name="BlockViewHandler"/>
<add name="BlockViewHandler" path="*" verb="*" preCondition="integratedMode" type="System.Web.HttpNotFoundHandler" />
</handlers>
</system.webServer>
</configuration>

Daniil
Sep 17, 2012, 2:16 PM
Please review this comment.



So, your web.config assembly binding is incorrect. Each assemblyIdentity and bindingRedirect must be in separate assemblyBinding (see web.config in my above quote )
Just move Ext.Net.Utilities to separate assemblyBinding

zwf
Sep 17, 2012, 3:00 PM
Please review this comment.
I'm sorry, but I did that now :

<runtime>
<assemblyBinding xmlns="urn:schemas-microsoft-com:asm.v1">
<dependentAssembly>
<assemblyIdentity name="System.Web.Helpers" publicKeyToken="31bf3856ad364e35" />
<bindingRedirect oldVersion="1.0.0.0" newVersion="2.0.0.0" />
</dependentAssembly>

<dependentAssembly>
<assemblyIdentity name="System.Web.Mvc" publicKeyToken="31bf3856ad364e35" />
<bindingRedirect oldVersion="1.0.0.0-3.0.0.0" newVersion="4.0.0.0" />
</dependentAssembly>
<dependentAssembly>
<assemblyIdentity name="System.Web.WebPages" publicKeyToken="31bf3856ad364e35" />
<bindingRedirect oldVersion="1.0.0.0" newVersion="2.0.0.0" />
</dependentAssembly>
</assemblyBinding>


<assemblyBinding xmlns="urn:schemas-microsoft-com:asm.v1">
<dependentAssembly>
<assemblyIdentity name="Ext.Net.Utilities" publicKeyToken="2c34ac34702a3c23" />
<bindingRedirect oldVersion="0.0.0-2.0.0" newVersion="2.0.1" />
</dependentAssembly>
</assemblyBinding>

</runtime>


4788

That's the result.

Vladimir
Sep 17, 2012, 3:03 PM
Did you remove ResourceManager from partial view (buttons.cshtml)?

Vladimir
Sep 17, 2012, 3:33 PM
By the way, your last posted web.config is correct. Each assemblyIdentity in separate dependent assembly.
Atleast your sample works fine in VS 2010.

I will try to test under VS 2012 (just my current OS is not supported by VS 2012)

Vladimir
Sep 17, 2012, 3:43 PM
By the way, you mentioned that you use IIS Express
Http handler and modlule must defined in the system.webServer section for IIS7 (not sure about IIS Express but it seems it is true for Express also)

Therefore please define Ext.Net http handler/module in sytem.webServer section, please section III in the following readme
http://examples2.ext.net/#/Getting_Started/Release_Documents/README/

Daniil
Sep 17, 2012, 7:24 PM
My question is, did you get Ext.Net running in VS2012 ?


Yes, I just got it running well with your project applying the following changes.

1. Please revert back the changes in the Web.config regarding assemblyBinding. The below was correct. I led you to change by a mistake.

Example

<runtime>
<assemblyBinding xmlns="urn:schemas-microsoft-com:asm.v1">
<dependentAssembly>
<assemblyIdentity name="System.Web.Helpers" publicKeyToken="31bf3856ad364e35" />
<bindingRedirect oldVersion="1.0.0.0" newVersion="2.0.0.0" />
</dependentAssembly>

<dependentAssembly>
<assemblyIdentity name="System.Web.Mvc" publicKeyToken="31bf3856ad364e35" />
<bindingRedirect oldVersion="1.0.0.0-3.0.0.0" newVersion="4.0.0.0" />
</dependentAssembly>
<dependentAssembly>
<assemblyIdentity name="System.Web.WebPages" publicKeyToken="31bf3856ad364e35" />
<bindingRedirect oldVersion="1.0.0.0" newVersion="2.0.0.0" />
</dependentAssembly>

<dependentAssembly>
<assemblyIdentity name="Ext.Net.Utilities" publicKeyToken="2c34ac34702a3c23" />
<bindingRedirect oldVersion="0.0.0-2.0.0" newVersion="2.0.1" />
</dependentAssembly>
</assemblyBinding>
</runtime>

2. The second change is related to this comment.


By the way, you mentioned that you use IIS Express
Http handler and modlule must defined in the system.webServer section for IIS7 (not sure about IIS Express but it seems it is true for Express also)

Therefore please define Ext.Net http handler/module in sytem.webServer section, please section III in the following readme
http://examples2.ext.net/#/Getting_Started/Release_Documents/README/

So, please add this into the Web.config.

<system.webServer>
<validation validateIntegratedModeConfiguration="false" />
<modules>
<add
name="DirectRequestModule"
preCondition="managedHandler"
type="Ext.Net.DirectRequestModule, Ext.Net"
/>
</modules>
<handlers>
<add
name="DirectRequestHandler"
verb="*"
path="*/ext.axd"
preCondition="integratedMode"
type="Ext.Net.ResourceHandler"
/>
</handlers>
</system.webServer>

zwf
Sep 18, 2012, 9:02 AM
That's it :)
Thanks !
It works now !

Many thanks !
Regards,
Holger

PS: Is there any further documentation regarding ext.net and razor ?
Especially concerning validation ?

Daniil
Sep 18, 2012, 12:27 PM
PS: Is there any further documentation regarding ext.net and razor ?
Especially concerning validation ?

Unfortunately, no.
http://forums.ext.net/showthread.php?17864&p=77122&viewfull=1#post77122

The forums and MVC examples (in SVN) are only things we can offer you for now.