PDA

View Full Version : [CLOSED] [2.0] ComboBox not rendering property in a FormPanel inside a Window



FVNoel
Aug 08, 2012, 7:54 AM

Daniil
Aug 08, 2012, 10:53 AM
Hi,

I am unable to reproduce.

Please try to remove:

Cls="noicono"

FVNoel
Aug 08, 2012, 11:26 AM
Tried to remove the Cls, but it does the same.

The combo is loaded at run time:


For Each Provincia As Provincias In Business.Provincias.getProvincias
cmbProvincia.Items.Add(New Ext.Net.ListItem(Provincia.Provincia, Provincia.Id.ToString))
Next

Daniil
Aug 08, 2012, 2:37 PM
Please ensure no other CSS affects on that ComboBox. I would remove just all CSS to check the issue will still be reproducible or not.

Is the issue reproducible in all browsers?

Please inspect the ComboBox HTML elements. What CSS rules does make this padding?

If the issue persist, please provide a full example which we could run without any changes.

FVNoel
Aug 09, 2012, 7:46 AM
Hello, this is the HTML code for the control which makes the padding:



<input id="ContentPlaceHolder1_CurriculumListControl1_Objeto_ FormControl_cmbProvincia-inputEl"
class="x-form-field x-form-text x-textfield-icon-input x-form-focus x-field-form-focus x-field-default-form-focus" type="text" style="width: 100%;
-moz-user-select: text;" name="ContentPlaceHolder1_CurriculumListControl1_Objeto_ FormControl_cmbProvincia"
autocomplete="off"aria-invalid="false" data-errorqtip="">


And this is the CSS:



.x-textfield-icon-input {
padding-left: 20px;
}


In ext.axd?v=0 (line 305)

Looks like the control is rendering as if it had an Icon, is there a way to specify I don't want to display it with an icon?

Daniil
Aug 09, 2012, 11:36 AM
That class should not appear if the ComboBox is configured without Icon and IconCls.

I guess somewhere in the code Icon or IconCls is applied for the ComboBox. Please check.

FVNoel
Aug 09, 2012, 12:07 PM
Thank you, that fixed the issue,

We had a generic function which clears all the form controls, setting default values for each control.
On the ComboBoxes we were setting IconCls to "" (empty string), and that was causing the issue.

Removed that line and they render properly.

Daniil
Aug 09, 2012, 12:26 PM
Maybe, it would be better to ignore IconCls if it's an empty string or, for example, not a sting at all.

Or leave it on developer's responsibility.

I will consider it with my colleague.

Daniil
Aug 09, 2012, 2:49 PM
We have added a change to ignore an empty sting.

I.e. setting up IconCls to an empty string won't add padding in your scenario.

Though, personally, I would avoid that setting.

Thanks for the question.