PDA

View Full Version : [CLOSED] Ext.Net status unlicensed in production server



sbg
Jul 23, 2012, 2:02 PM
Hello,

i have put in configSection this

<section name="extnet" type="Ext.Net.GlobalConfig" requirePermission="false"/>

and, in configuration this:


<extnet theme="Gray" licenseKey="xxxxx____license____xxxx" />
</configuration>

All works fine but we got the license warning (status: unlicensed) navigating some pages on a production server.
Of course I have registered the DirectRequestModule and the ResourceHandler, too.

Is there something I miss? How can I see why some pages show the warning?
Note: i see the warning after the our last update of Ext.NET 2.0 from SVN (July, 20th).

Thanks in advance

Vladimir
Jul 23, 2012, 3:11 PM
Status can be unlincesed if
- ResourceManager cannot read web.config
- key is not defined in extnet section
- key is invalid

Do you able to determine what kind of pages have license warning? What difference between normal (where the warning is not appeared) and pages with the warning?

Do you able to create test project reproduces the issue and send to me (vladimir@object.net) ?

sbg
Jul 24, 2012, 6:16 AM
Do you able to determine what kind of pages have license warning? What difference between normal (where the warning is not appeared) and pages with the warning?


They are aspx pages in TreePanels (TreePanel -> Panel -> Loader).



Do you able to create test project reproduces the issue and send to me (vladimir@object.net) ?

I will try,
thank you

sbg
Jul 27, 2012, 1:11 PM
Sorry, we still have the problem.
We have also tried adding the license key in the Global.asax:


protected void Application_Start(Object sender, EventArgs e)
{
// ext.net license:
Application["Ext.Net.LicenseKey"] = "Our license key";



Can you check our license key, if it is valid? We hadn't this problem in the early 2.0 versions.

Regards

Daniil
Jul 27, 2012, 1:19 PM
Can you check our license key, if it is valid? We hadn't this problem in the early 2.0 versions.


Please email a request with your forum name on:
support@object.net

Vladimir
Jul 27, 2012, 2:02 PM
Hi,

What value returns IsValidLicenseKey property of ResourceMansger?
If false then can you try to debug that property to determone why it returns false (place breakpoint inside getter of IsValidLicenseKey, it requires source code of Ext.Net, file: svn.ext.net\branches\2.1\Ext.Net\Core\ResourceMana ger\License.cs)

sbg
Jul 30, 2012, 7:40 AM
Hi,

we have finally found the cause of the issue. The problem is the Visual Studio command "Tools/Generate Local Resources" used to generate the resx file of the aspx. If you have this in a page:


<ext:ResourceManager ID="ResourceManager1" runat="server" />

Then you launch Tools/Generate Local Resources, the generator will replace that with:



<ext:ResourceManager ID="ResourceManager1" runat="server"
ContentUpdated="False" LicenseKey="" Locale="en-US" />


And this will override the LicenseKey specifications generating the popup. The strange thing is that the message is not shown on development machine.

Daniil
Jul 30, 2012, 9:08 AM
Then you launch Tools/Generate Local Resources, the generator will replace that with:



<ext:ResourceManager ID="ResourceManager1" runat="server"
ContentUpdated="False" LicenseKey="" Locale="en-US" />



Reproduced. Not sure we can affect on that. Though we will look.



And this will override the LicenseKey specifications generating the popup.

Yes, the ResourceManager LicenseKey property has a higher priority than the licenseKey option within the Web.config.



And this will override the LicenseKey specifications generating the popup.

It should only appears when you deploy the site/application. There is no license check if the site/application is launched locally.

Vladimir
Jul 30, 2012, 10:34 AM
Thanks for the report, we will fix it soon

Daniil
Aug 03, 2012, 5:44 PM
The issue has been fixed in SVN.

Thanks again for the report.