PDA

View Full Version : [CLOSED] Downloading Ext.NET 2.0 Beta with Nuget problem



CarWise
May 29, 2012, 8:45 AM
Hi,

Trying to download 2.0 beta, but I'm getting an error and the package is not installed. MVC 3.0 is installed. How to solve this issue ?

This is showed:


PM> Install-Package Ext.NET -Pre
Attempting to resolve dependency 'Transformer.NET (≥ 2.0.0)'.
Attempting to resolve dependency 'Ext.NET.Utilities (≥ 2.0.1)'.
Attempting to resolve dependency 'Newtonsoft.Json (≥ 4.5.5)'.
You are downloading Transformer.NET from Ext.NET Inc., the license agreement to which is available at http://www.ext.net/licensetransformer/. Check the package for additional dependencies, which may come with their own license agreement(s). Your use of the package and dependencies constitutes your acceptance of their license agreements. If you do not accept the license agreement(s), then delete the relevant components from your device.
Successfully installed 'Transformer.NET 2.0.0'.
You are downloading Ext.NET.Utilities from Ext.NET Inc., the license agreement to which is available at http://www.ext.net/licenseutilities/. Check the package for additional dependencies, which may come with their own license agreement(s). Your use of the package and dependencies constitutes your acceptance of their license agreements. If you do not accept the license agreement(s), then delete the relevant components from your device.
Successfully installed 'Ext.NET.Utilities 2.0.1'.
Successfully installed 'Newtonsoft.Json 4.5.5'.
You are downloading Ext.NET from Ext.NET Inc., the license agreement to which is available at http://www.ext.net/licensepro/. Check the package for additional dependencies, which may come with their own license agreement(s). Your use of the package and dependencies constitutes your acceptance of their license agreements. If you do not accept the license agreement(s), then delete the relevant components from your device.
Successfully installed 'Ext.NET 2.0.0-beta3'.
Successfully added 'Transformer.NET 2.0.0' to SupportExt.
Successfully added 'Ext.NET.Utilities 2.0.1' to SupportExt.
Successfully added 'Newtonsoft.Json 4.5.5' to SupportExt.
Successfully uninstalled 'Ext.NET 2.0.0-beta3'.
Successfully uninstalled 'Newtonsoft.Json 4.5.5'.
Successfully uninstalled 'Ext.NET.Utilities 2.0.1'.
Successfully uninstalled 'Transformer.NET 2.0.0'.
Install failed. Rolling back...
Install-Package : Failed to add reference to 'System.Web'. Please make sure that it is in the Global Assembly Cache.
At line:1 char:16
+ Install-Package <<<< Ext.NET -Pre
+ CategoryInfo : NotSpecified: (:) [Install-Package], InvalidOperationException
+ FullyQualifiedErrorId : NuGetCmdletUnhandledException,NuGet.PowerShell.Com mands.InstallPackageCommand

CarWise
May 29, 2012, 10:31 AM
Used SVN. Downloaded now..

But, what caused above problem ?

Martin

Daniil
May 29, 2012, 2:14 PM
Hi,

I am unable to reproduce, have just tried ti install with success.


Install-Package : Failed to add reference to 'System.Web'.
Please make sure that it is in the Global Assembly Cache.

So, is System.Web in the Global Assembly Cache? Are you able to add System.Web reference in a standard way (References => Add Reference ...)?

What is the version of NuGet Package Manager? If not the latest, please update and re-test.

CarWise
May 31, 2012, 7:31 AM
Hi,

I am unable to reproduce, have just tried ti install with success.


Install-Package : Failed to add reference to 'System.Web'.
Please make sure that it is in the Global Assembly Cache.

So, is System.Web in the Global Assembly Cache? Are you able to add System.Web reference in a standard way (References => Add Reference ...)?

What is the version of NuGet Package Manager? If not the latest, please update and re-test.

I'am not sure why it didn't succeed last Tuesday. I've tried again and it installed without any problem ..

Case closed.. sorry for your time.

Martin