PDA

View Full Version : [CLOSED] Bug on the TreePanel...



RCN
Apr 24, 2012, 2:33 PM
Hi,

When the West Panel of the Viewport has HeaderPosition="None" the TreePanel inside does not show it's items. Example:

<body>
<%--Formulário da página--%>
<form id="_frmPrincipal" runat="server">
<%--Gerenciador de recursos do ext.net--%>
<ext:ResourceManager ID="_rsmGerenciadorDeRecursos" CleanRequestUrl="false" ShowWarningOnAjaxFailure="false"
runat="server">
</ext:ResourceManager>
<%--Corpo base da página. Componente que divide a página em áreas.--%>
<ext:Viewport ID="_vwpCorpo" Cls="cls_vwp_ViewportPrincipal" Layout="BorderLayout"
runat="server">
<Items>
<%--Painel localizado na Área Oeste da página.--%>
<ext:Panel ID="_pnlAreaOeste" Region="West" Width="200" Collapsible="true" HeaderPosition="None"
Split="true" AnimCollapse="true" MinWidth="200" Layout="AccordionLayout" Icon="ApplicationCascade"
CollapseMode="Mini" runat="server" Margins="0 0 0 0">
<Items>
<%--Menu de aplicações do Sistema--%>
<ext:TreePanel ID="_trpMenu" runat="server" Draggable="false" Icon="ApplicationCascade"
AutoScroll="true" EnableDD="false" Animate="true" RootVisible="false" Title="Menu">
<Root>
<%--Nó inicial do menu de aplicações--%>
<ext:Node NodeID="0" Expanded="true" AllowDrag="false">
<Children>
<ext:Node NodeID="1" Text="Teste 1">
</ext:Node>
</Children>
</ext:Node>
</Root>
</ext:TreePanel>
</Items>
</ext:Panel>
</Items>
</ext:Viewport>
</form>
</body>
When i change the HeaderPosition="None" for PreventHeader="true" on the west Panel, it works just fine.

I'm using PreventHeader, so, no problem. This post it is just to notify you.

Happy to be of service,

Daniil
Apr 25, 2012, 10:59 AM
Hi,

Yes, please use

PreventHeader="true"
to prevent a Header from being created and shown.

This option

HeaderPosition="None"
doesn't prevent a Header.

Daniil
Dec 09, 2013, 6:29 AM
PreventHeader has been marked deprecated by ExtJS:
http://docs.sencha.com/extjs/4.2.1/#!/api/Ext.panel.Panel-cfg-preventHeader

So, please pick Header instead.

Header="false" prevents a header.

RCN
Dec 09, 2013, 11:09 AM
Thank you Daniil