PDA

View Full Version : [CLOSED] SVN updated compiled version problem while accessing from remote computer



sailendra
Apr 24, 2012, 8:19 AM
SVN updated compiled version when accessed from remote computer not working

in case of firefox it gives "A script on this page may be busy, or it may have stopped responding. You can stop the script now, or you can continue to see if the script will complete."

in case of chrome the page is not rendered at all, so after sometime browser error page comes up,

but it is running well when accessed from the same computer, attached the example with ext dll,

so do i need any configuration in IIS 7 to access from remote computer?

Daniil
Apr 24, 2012, 11:54 AM
Hi,

There must be the following settings for IIS 7 in Web.config.


IIS 7 settings

<system.webServer>
<validation validateIntegratedModeConfiguration="false"/>
<modules>
<add
name="DirectRequestModule"
preCondition="managedHandler"
type="Ext.Net.DirectRequestModule, Ext.Net"
/>
</modules>
<handlers>
<add
name="DirectRequestHandler"
verb="*"
path="*/ext.axd"
preCondition="integratedMode"
type="Ext.Net.ResourceHandler"
/>
</handlers>
</system.webServer>

sailendra
Apr 24, 2012, 2:05 PM
<?xml version="1.0"?>
<configuration>
<configSections>
<section name="extnet" type="Ext.Net.GlobalConfig" requirePermission="false"/>
</configSections>
<extnet scriptMode="Debug" />
<appSettings>
<add key="ShowHiddenExamples" value="False"/>
</appSettings>


<system.web>
<!-- DO NOT change this trust level. Application MUST run in "Medium" trust. -->
<!-- Full trust is required for the FeedViewer example because of outbound HTTP requests to fetch RSS feeds -->
<trust level="Medium"/>
<webServices>
<protocols>
<add name="HttpGet"/>
<add name="HttpPost"/>
</protocols>
</webServices>
<customErrors mode="Off">
<error statusCode="404" redirect="~/404.aspx"/>
</customErrors>
<compilation debug="true" targetFramework="4.0">
<assemblies>
<add assembly="System.Data.Linq, Version=4.0.0.0, Culture=neutral, PublicKeyToken=B77A5C561934E089"/>
</assemblies>
</compilation>
<authentication mode="Windows">

</authentication>
<pages controlRenderingCompatibilityVersion="3.5" clientIDMode="AutoID">
<controls>

<add tagPrefix="ext" namespace="Ext.Net" assembly="Ext.Net"/>

</controls>
</pages>
<httpHandlers>
<add path="*/ext.axd" verb="*" type="Ext.Net.ResourceHandler" validate="false"/>
</httpHandlers>
<httpModules>
<add name="DirectRequestModule" type="Ext.Net.DirectRequestModule, Ext.Net"/>

</httpModules>
</system.web>
<!--
The system.webServer section is required for running ASP.NET AJAX under Internet
Information Services 7.0. It is not necessary for previous version of IIS.
-->
<system.webServer>
<validation validateIntegratedModeConfiguration="false"/>
<modules>
<add name="DirectRequestModule" preCondition="managedHandler" type="Ext.Net.DirectRequestModule, Ext.Net"/>

</modules>
<handlers>
<add name="DirectRequestHandler" verb="*" path="*/ext.axd" preCondition="integratedMode" type="Ext.Net.ResourceHandler"/>
</handlers>
</system.webServer>
</configuration>



My web.config already contains that configuration, but somehow when access from remote computer it is not working.

Vladimir
Apr 24, 2012, 2:13 PM
Can you post a link to online sample which we can test?

Daniil
Apr 24, 2012, 2:16 PM
How long ago did you update from SVN?

Recently, there was a bug which produced the error you described:
"A script on this page may be busy, or it may have stopped responding. You can stop the script now, or you can continue to see if the script will complete."

Please update now and re-test. Just to ensure it's reproducible or not with the latest sources.

sailendra
Apr 24, 2012, 3:28 PM
Hi,

This is the link



svn update date is 24 April 2012.

Vladimir
Apr 24, 2012, 3:46 PM
Thanks for the report. Fixed in SVN
Please update and retest

sailendra
Apr 24, 2012, 4:13 PM
Thanks, now it is working