EXT.NET 3.0.0 RELEASED!
Now with Tablet Support!
Ext.NET 3.0.0 is here with lots of new cool features and now with tablet support! Check Examples Explorer now to see it in action or download and test it yourself for free!
Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: HtmlEditor

  1. #1
    Member
    Join Date
    Feb 2008
    Location
    Posts
    14

    HtmlEditor

    Hi,



    I have downloaded this cool toolkit for ExtJs. I have included the HtmlEditor in a Window but when i run my project i am not able to apply formatting in HtmlEditor as the buttons are disabled





    my code





    Code:
        <cool:ScriptManager ID="ScriptManager1" runat="server" />
    
        
    
            <cool:Window ID="wLogin" runat="server" Title="IHCVE Login" AutoShow="true" Modal="true"  Height="400" Width="600" Closable="false" MonitorResize="true">
    
                <Content>
    
                    <cool:HtmlEditor ID="HtmlEditor1" runat="server" AutoShow="true" CreateLinkText="Click to create link" >
    
                        <%--<ClientEvents>
    
                            
    
                        </ClientEvents>--%>
    
                    </cool:HtmlEditor>
    
                </Content>
    
            </cool:Window>




    What am i doing wrong?
    Attached Images Attached Images

  2. #2
    Member
    Join Date
    Feb 2008
    Location
    Posts
    14

    RE: HtmlEditor

    why i m not able to see the code which i posted in above post? i am also not able to edit my post :(

  3. #3
    Ext.NET - Dev Team geoffrey.mcgill's Avatar
    Join Date
    Jan 2008
    Location
    Canada
    Posts
    8,695

    RE: HtmlEditor

    Ok, the "code" tags don't appear to be working. I'll try to get this working immediately.
    Geoffrey McGill
    Ext.NET, Inc.
    Founder, and Dev Team

    Ext.NET Examples | Ext.NET API Docs | ExtJS API Docs | @extnet | Jobs

  4. #4
    Ext.NET - Dev Team geoffrey.mcgill's Avatar
    Join Date
    Jan 2008
    Location
    Canada
    Posts
    8,695

    RE: HtmlEditor

    The html editor used by this forum software does not appear to be parsing/stripping the '<' bracket correctly in FireFox. We're working on a fix.
    Geoffrey McGill
    Ext.NET, Inc.
    Founder, and Dev Team

    Ext.NET Examples | Ext.NET API Docs | ExtJS API Docs | @extnet | Jobs

  5. #5
    Ext.NET - Dev Team geoffrey.mcgill's Avatar
    Join Date
    Jan 2008
    Location
    Canada
    Posts
    8,695

    RE: HtmlEditor

    Does the HtmlEditor work if you remove the AutoShow="true" attribute from the tag?

    One other problem I think you're going to have with the current release (v0.3) is the Form controls (HtmlEditor included) will not postback their values when used inside a Window control. The html generated by the Window control is moved outside the <form> when the Window is rendered client-side. We're working on a fix.
    Geoffrey McGill
    Ext.NET, Inc.
    Founder, and Dev Team

    Ext.NET Examples | Ext.NET API Docs | ExtJS API Docs | @extnet | Jobs

  6. #6
    Member
    Join Date
    Feb 2008
    Location
    Posts
    14

    RE: HtmlEditor

    geoffrey.mcgill (2/19/2008)Does the HtmlEditor work if you remove the AutoShow="true" attribute from the tag?

    </p>

    One other problem I think you're going to have with the current release (v0.3) is the Form controls (HtmlEditor included) will not postback their values when used inside a Window control. The html generated by the Window control is moved outside the <form> when the Window is rendered client-side. We're working on a fix.
    </p>

    <br class="webkit-block-placeholder"></p>

    No it is still not working. I have moved the HTMLEditor code out side of Window</p>

    <br class="webkit-block-placeholder"></p>

    here is the code...I have also attached output which i am getting.</p>

    <br class="webkit-block-placeholder"></p>

    Code:
    </p>
    
    <%@ Page Language="C#" AutoEventWireup="true" テつ*CodeFile="Default.aspx.cs" Inherits="_Default" %>
    <br class="webkit-block-placeholder">
    <%@ Register Assembly="Coolite.Web.UI" Namespace="Coolite.Web.UI" TagPrefix="cool" %>
    <br class="webkit-block-placeholder">
    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
    <br class="webkit-block-placeholder">
    <html xmlns="http://www.w3.org/1999/xhtml" >
    <head runat="server">
    テつ*テつ* テつ*<title>Untitled Page</title>
    </head>
    <body>
    テつ*テつ* テつ*<form id="form1" runat="server">
    テつ*テつ* テつ*<cool:ScriptManager ID="ScriptManager1" runat="server" />
    テつ*テつ* テつ*
    テつ*テつ* テつ* テつ*<%-- テつ*<cool:Window ID="wLogin" runat="server" Title="IHCVE Login" AutoShow="true" Modal="true" テつ*Height="400" Width="600" Closable="false" MonitorResize="true">
    テつ*テつ* テつ* テつ* テつ* テつ* テつ*<Content>--%>
    テつ*テつ* テつ* テつ* テつ* テつ* テつ* テつ* テつ*<cool:HtmlEditor ID="HtmlEditor1" runat="server" CreateLinkText="Click to create link" >
    テつ*テつ* テつ* テつ* テつ* テつ* テつ* テつ* テつ* テつ* テつ*<%--<ClientEvents>
    テつ*テつ* テつ* テつ* テつ* テつ* テつ* テつ* テつ* テつ* テつ* テつ* テつ*
    テつ*テつ* テつ* テつ* テつ* テつ* テつ* テつ* テつ* テつ* テつ*</ClientEvents>--%>
    テつ*テつ* テつ* テつ* テつ* テつ* テつ* テつ* テつ*</cool:HtmlEditor>
    テつ*テつ* テつ* テつ* テつ* テつ* テつ* テつ* テつ*
    テつ*テつ* テつ* テつ* テつ* テつ* テつ* テつ* テつ*<cool:Calendar ID="Calendar1" runat="server">
    テつ*テつ* テつ* テつ* テつ* テつ* テつ* テつ* テつ*</cool:Calendar>
    テつ*テつ* テつ* テつ* テつ* テつ* <%-- </Content>
    テつ*テつ* テつ* テつ* テつ*</cool:Window>
    テつ*テつ* テつ* テつ* テつ*--%>
    テつ*テつ* テつ*
    
    テつ*テつ* テつ*</form>
    </body>
    </html>
    <br class="webkit-block-placeholder">
    </p>
    </p>
    Attached Images Attached Images
    • File Type: jpg 1.JPG (71.6 KB, 77 views)

  7. #7
    Ext.NET - Dev Team geoffrey.mcgill's Avatar
    Join Date
    Jan 2008
    Location
    Canada
    Posts
    8,695

    RE: HtmlEditor



    Very strange.

    I get that exact same behaviour in IE+FF when AutoShow="true". When I remove AutoShow everything is good.

    Any possiblitiy your browser could be caching?

    As well, posting the block of Ext.onReady script that gets written to the head of the Page may help us diagnose.


    Geoffrey McGill
    Ext.NET, Inc.
    Founder, and Dev Team

    Ext.NET Examples | Ext.NET API Docs | ExtJS API Docs | @extnet | Jobs

  8. #8
    Ext.NET - Dev Team geoffrey.mcgill's Avatar
    Join Date
    Jan 2008
    Location
    Canada
    Posts
    8,695

    RE: HtmlEditor



    We've fixed the postback problem with window. The <cool:Window> control will now postback it's content to the Page.

    The following sample demonstrates a simple example.

    Code:
    <%@ Page Language="C#" %>
    
    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" 
        "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
    
    <script runat="server">
        protected void Button1_Click(object sender, EventArgs e)
        {
            this.Label1.Text = "You entered: " + this.TextBox1.Text;
        }
    </script>
    
    <html xmlns="http://www.w3.org/1999/xhtml" >
    <head id="Head2" runat="server">
        <title>Ext Window with PostBack</title>
    </head>
    <body>
        <form id="form1" runat="server">
            
            <cool:ScriptManager ID="ScriptManager1" runat="server" />
    
            <asp:Label ID="Label1" runat="server" />
            <cool:Window 
                ID="Window1" 
                runat="server" 
                AutoShow="True" 
                BodyStyle="padding: 6px;" 
                Collapsible="True">
                <Content>
                    <asp:TextBox ID="TextBox1" runat="server" /><br />
                    <asp:Button runat="server" id="Button1" Text="submit" &#111;nclick="Button1_Click" />
                </Content>
            </cool:Window>
                    
        </form>
    </body>
    </html>
    As far as the other rendering problem you noted, I'm almost 100% positive it was because the AutoShow property was set to true.

    Please let us know if it's still giving you problems.

    The new Window with postback support will be available with the next release (v0.4) due out at the end of the February.

    If you're desperate for the fix, pm me and I'll get you a build.
    Geoffrey McGill
    Ext.NET, Inc.
    Founder, and Dev Team

    Ext.NET Examples | Ext.NET API Docs | ExtJS API Docs | @extnet | Jobs

  9. #9
    Member
    Join Date
    Feb 2008
    Location
    Posts
    14

    RE: HtmlEditor

    テつ*It is working fine now.<br class="webkit-block-placeholder">
    however i encountered a new problem..
    <br class="webkit-block-placeholder">
    I have added HtmlEditor in the example u posted in previous post. when i try to collapse the window which contains the editor it replaces its contents with "false". This is happening only in Firefox.

  10. #10
    Ext.NET - Dev Team geoffrey.mcgill's Avatar
    Join Date
    Jan 2008
    Location
    Canada
    Posts
    8,695

    RE: HtmlEditor

    Hi arya009,

    The HtmlEditor displaying 'false' is unfortunately caused by a bug in FF (and Safari). At the moment there are some limitations as to where the HtmlEditor can be placed. Any location where the container is hidden (i.e. Window collapse/expand) will render this bug.

    Adding the HtmlEditor to a Window works fine, just not collapsing a Window with an HtmlEditor inside.

    I have a theory on how to work around, but have yet to get something solid. I'm devoting some time today to figure out this problem.

    I'll do my best to keep this thread updated.
    Geoffrey McGill
    Ext.NET, Inc.
    Founder, and Dev Team

    Ext.NET Examples | Ext.NET API Docs | ExtJS API Docs | @extnet | Jobs

Similar Threads

  1. [CLOSED] ListView with HtmlEditor -> HtmlEditor value is null
    By SouthDeveloper in forum 1.x Premium Help
    Replies: 8
    Last Post: Apr 17, 2012, 1:50 AM
  2. HtmlEditor Render Bug
    By htmlEditor in forum 1.x Help
    Replies: 6
    Last Post: Sep 13, 2011, 9:57 PM
  3. HtmlEditor not working with Ext.NET 1.0 RC1
    By beufreecasse in forum 1.x Help
    Replies: 2
    Last Post: Jun 14, 2011, 12:07 AM
  4. HtmlEditor -- Remove <P> tag
    By bmagana in forum 1.x Help
    Replies: 0
    Last Post: Jun 09, 2011, 6:46 PM
  5. HtmlEditor contains
    By okutbay in forum 1.x Help
    Replies: 0
    Last Post: May 06, 2010, 10:37 AM

Posting Permissions